Forum: SuRun Probleme RSS
Problem mit Programmfilter
Jared77 #1
Mitglied seit 10/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: Problem mit Programmfilter
Bin gerade über in komisches Problem gestolpert  8-(

Und zwar habe ich den Defraggler installiert und ihn als
automatisch und immer mit erhöhten Rechten starten konfiguriert.

Funktioniert soweit sehr gut. Aber ...

habe nun mal ein der Eingabeaufforderung folgendes eingegeben:

start http://www.piriform.com/Defraggler

Es sollte sich nun mein Browser (Opera) mit der Seite öffnen,
aber Surun funkt dazwischen und startet den Defraggler.

PS: benutzte Surun 1.2.1.1 beta 4 unter Windows 7 x64
Kay (Administrator) #2
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Ich habe gerade Defraggler unter meinem Win7 x64 installiert und habe das Problem nicht.
Was genau startet SuRun bei Dir automatisch mit gehobenen Rechten?
Bei mir: "C:\Program Files\Defraggler\Defraggler64.exe"
Jared77 #3
Mitglied seit 10/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Zitat von Kay:
Was genau startet SuRun bei Dir automatisch mit gehobenen Rechten?
Bei mir: "C:\Program Files\Defraggler\Defraggler64.exe"

Ja genau so heißt der Pfad bei mir auch.
Ich glaube ich weiß jetzt auch woran es liegt.

in der Registry unter:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\defraggler.exe
(Standard) = C:\Program Files\Defraggler\Defraggler64.exe
Path = C:\Program Files\Defraggler

habe ich diesen Pfad auch gefunden.
wenn ich den (Standard) Wert ändere funktioniert wieder alles.

Bin mir aber sicher das ich diese Registrywerte nicht selbst erstellt habe.
Kay (Administrator) #4
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Bei mir steht dasselbe in der Registry und macht keine Probleme.
Vielleicht hängt sich bei Dir ein URL-Filter dazwischen, der dann aus http://www.piriform.com/Defraggler ShellExecute("Defraggler") macht.

Was sagt der Debug-Output von SuRun über den Autostart aus?
Kannst Du den hier mal posten?
Jared77 #5
Mitglied seit 10/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hier der Debug output von Dbgview.exe

00000001    0.00000000    [3000] .\SuRunext.cpp(630): SuRun ShellExtHook: msk=140 verb=(null), file=http://www.piriform.com/Defraggler, parms=, dir=(null), idlist=0, class=(null), hkc=0, hProc=0   
00000002    0.01864005    [3076] .\main.cpp(86): SuRun started with (C:\Windows\SuRun.exe /QUIET /TESTAA 3000 000007FEFA2A62A8 "C:\Program Files\Defraggler\Defraggler64.exe")   
00000003    0.04495240    [3748] .\main.cpp(86): SuRun started with (C:\Windows\SuRun.exe /AskUSER)   
00000004    0.10623578    [3000] .\SuRunext.cpp(759): SuRun ShellExtExecute(C:\Windows\SuRun.exe /QUIET /TESTAA 3000 000007FEFA2A62A8 "C:\Program Files\Defraggler\Defraggler64.exe"), PID=3244 intercepted   
00000005    0.11439724    [2876] .\main.cpp(86): SuRun started with (C:\Windows\SuRun.exe)
Kay (Administrator) #6
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hab's gefunden, aber noch nicht behoben.

Keine Ahnung, warum das Problem bei mir erst nach einem Neustart auftrat.

Ich melde mich wieder.
Kay (Administrator) #7
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Es war ein Bug in SuRun's Kommandozeilen-Auflöser.

Wenn Du ein Programm einfach über den Namen startest z.B. "Defraggler", sieht Explorer in HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths und in HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths nach, ob es einen Eintrag für Defraggler|.exe|.com|.lnk etc. gibt.

SuRun macht das auch, aber bisher falsch.  :blush:
SuRun sieht auch bei Kommandozeilen, wie <beliebigezeichenhierher>/Defraggler dort nach, findet den Eintrag für "Defraggler.exe" und startet das mit gehobenen Rechten.
Das klappt bei mir auch mit "surun asdgahalkdfjgsbhlvuzlerut/coreldrw".
Mist!  :huh:

Es wird mit SuRun 1.2.1.1b5 behoben sein.
Jared77 #8
Mitglied seit 10/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Gut, bis auf diese Kleinigkeit läuft SuRun wirklich perfekt.

Wird es den zu Weihnachten wieder eine Final geben?
Kay (Administrator) #9
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Ich hoffe.

Bin gerade noch an der Consolen-Geschichte dran und habe den Bug in Online Armor gefunden.
Mik.c.OS #10
Benutzertitel: scriptkiddy :D
Mitglied seit 12/2007 · 338 Beiträge · Wohnort: Europa
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
bloß nicht stressen lassen, und wenns erst nach neujahr kommt.
qualität statt quantität! ;-)
[0001 0110]
Mik.c.OS Shell Extensions for SuRun (rev3.1) [2010-10-27] ("The Ugly One" :D )
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Gehe zu Forum
Nicht angemeldet. · Kennwort vergessen · Registrieren
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Seite erstellt in 161,4 ms (51,3 ms) · 101 Datenbankabfragen in 24 ms
Aktuelle Zeit: 18.12.2017, 23:06:17 (UTC +01:00)