Forum: SuRun Beta RSS
SuRun 1.2.1.1
Seite:  vorherige  1  2  3  4  nächste 
Avatar
0strodamus #31
Mitglied seit 11/2012 · 6 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Antwort auf Beitrag ID 3897
Hi Kay. I'm having issues running Surun with NoVirusThanks EXE Radar Pro. The issue appears to be related to Surun's all processes hooking. I posted a more detailed description of the problem I'm seeing here. Do you have any tips on how I might be able to get Surun to work with this application?
Kay (Administrator) #32
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
I just tried Exe Radar Pro (ERP) with SuRun 1.2.1.0 and SuRun 1.2.1.1b7 inside a Win7x64 VM and had no big problems. (To not complain that the trial period expired, ERP has to be launched with elevated rights on my VM.)

I need to reproduce your issue here:
  • What does not work on your VM?
  • What HIPS besides ERP do you use on your VM?
Avatar
0strodamus #33
Mitglied seit 11/2012 · 6 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hi Kay. Thanks for the quick response. What isn't working is that no applications will launch. I also had Emsisoft Anti-Malware installed in the VM. I didn't make any tests with that uninstalled. I will make some more tests and post back; my suspicion now is that Emsisoft may be the cause of the conflicts. I had both Surun and ERP whitelisted in Emsisoft's behavior blocker. Sorry for any trouble I've caused you due to my lack of thorough testing before posting. :blush:
Avatar
0strodamus #34
Mitglied seit 11/2012 · 6 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hi Kay. I did some more testing and, oddly enough, I was getting the ERP trial expiration warnings today too. That wasn't happening yesterday during my tests. The program would run fine under my limited user account. Anyway, the issue is resolved by running EXERadar.exe as administrator. I was completely unable to reproduce the errors I had yesterday. I was able to re-install Exe Radar Pro (ERP) on my real machine and as long as I don't enable the "Startup with Windows" option in the program and create my own Surun enabled startup entry under HKCU, I'm ok.

Again, my apologies for posting without testing more thoroughly. I should have thought to try running EXERadar.exe as administrator yesterday, but because of the ERPx64Svc.exe executable I didn't think it was necessary. Your observation prompted me to do that, so I thank you very much for that. Have a great day and thank you for all the help and for providing such a wonderful program. :-)
Kay (Administrator) #35
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
One is glad to be of service ;-)
Jared77 #36
Mitglied seit 10/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Antwort auf Beitrag ID 3797
Zitat von Kay am 12.11.2012, 19:04:
SuRun 1.2.1.1b2 - 2012-11-12
  • FIX: In Windows 8 hat der IAT-Hook unzureichend funktioniert, da die API-Sets jetzt durch DLLs mit Namen "api-ms-win-*-l1-1-1.dll" (statt "api-ms-win-*-l1-1-0.dll" in Windows 7) implementiert sind

Hallo Kay,

mit Windows 8.1 gibt es wieder neue Versionen dieser API-Sets.
Diese 2 kennt der aktuelle IAT-Hook noch nicht:

api-ms-win-core-libraryloader-l1-2-0.dll
api-ms-win-core-processthreads-l1-1-2.dll
Kay (Administrator) #37
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Danke für den Tipp. Hab's intern eingebaut... bin am basteln einer Win81-VM.
Kay (Administrator) #38
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
...sooo der Sommer ist rum. Ich hatte heute etwas Zeit zum Programmieren.

SuRun 1.2.1.1b8 - 2013-09-03
  • NEU: Option zum Verstecken des grünen Smiley-Symbols in der Taskleiste
  • CHG: Kommandozeilen, die ein "://" vor dem ersten Leerzeichen haben werden von den Hooks ignoriert
  • CHG: SuRun's "Manifest"-Dateien unterstützen die Betriebssysteme Windows 8 und 8.1
  • FIX: Der IAT-Hook unterstützt die Windows 8.1 "api-ms-win-*-l1-*" DLLs und damit Windows 8.1
  • FIX: Das Speichern von Kennworten hat in Windows 2000 nicht funktioniert
Der Autor hat eine Datei an diesen Beitrag angehängt:
SuRun1211b8.zip | Speichern   962,3 kBytes, 496 mal heruntergeladen
LeastPrivileges #39
Mitglied seit 06/2013 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hello,

The current SuRun Beta version 1.2.1.1b8 will not autorun shortcut (.lnk) files:

C:\Users\USERNAME\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup\AUTOBACK.lnk

Shortcut file path:

C:\WINDOWS\SuRun.exe "C:\Program Files (x86)\ERUNT\AUTOBACK.EXE" C:\WINDOWS\ERDNT\#Date# /noconfirmdelete /noprogresswindow /days:7

SuRun version 1.2.1.0 will autorun shortcut files ok.
Kay (Administrator) #40
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
I just tried this and it works here:
  • Copy Erunt to "C:\Program Files (x86)\ERUNT"
  • create a link to C:\WINDOWS\SuRun.exe "C:\Program Files (x86)\ERUNT\AUTOBACK.EXE" C:\WINDOWS\ERDNT\#Date# /noconfirmdelete /noprogresswindow /days:7 with working directory C:\Program Files (x86)\ERUNT in c:\Users\Kay\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
  • grant access to "C:\Program Files (x86)\ERUNT\AUTOBACK.EXE" C:\WINDOWS\ERDNT\#Date# /noconfirmdelete /noprogresswindow /days:7 in SuRun
  • restart system (Win7pro x64)
After restart a new folder c:\Windows\ERDNT\30.11.2013 has been created.
In my first turn i forgot to grant access to Autoback in SuRun and SuRun asked me if I intended to start Autoback with elevation.
Even if I delete C:\WINDOWS\SuRun.exe from the command line for Autoback SuRun starts it automagically elevated.

I first need to reproduce the issue here.

I assume you use Win7x64(?).
What HIPS/AV/Malware prevention tools do you run on your system?

Cheers

Kay
LeastPrivileges #41
Mitglied seit 06/2013 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
I assume you use Win7x64(?).
Yes.

What HIPS/AV/Malware prevention tools do you run on your system?
None at all. I have Software Restriction Policies enabled, but I have made sure nothing is blocking SuRun or ERUNT. The Windows firewall is enabled, but running with default settings, I turned it off as a test, but it didn't make any difference. I uninstalled v1.2.1.0, reinstalled v1.2.1.1b8, deleted today's ERDNT back up, rebooted the PC and it didn't back up. If I double-click on the shortcut file manually, it backs up just fine, but it won't run by itself during startup. This is strange.

Windows 7 (x64)
No AV
No HIPS
Windows Firewall turned off
Software Restriction Policies enabled
LeastPrivileges #42
Mitglied seit 06/2013 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
I am now testing in VMware.

Windows 7 (x64) Ultimate
No AV
No HIPS
No Firewall enabled
No Software Restriction Policies enabled

Version 1.2.1.0 always runs the shortcut file in the Startup folder once I give SuRun the Windows password. Version 1.2.1.1b8 never runs the shortcut file even after I give SuRun the Windows password. It might be a bug in the password settings.

Here is my v1.2.1.1b8 settings:

[SuRun]
Version=1.2.1.1ß8
BlurDesk=0
FadeDesk=0
SavePW=1
UseCancelTimeOut=0
CancelTimeOut=40
ShowCancelTimeOut=0
PwTimeOut=0
AdminNoPassWarn=4
CtrlAsAdmin=0
CmdAsAdmin=0
ExpAsAdmin=0
RestartAsAdmin=0
StartAsAdmin=0
HideExpertSettings=0
UseIShExHook=1
UseIATHook=1
TestReqAdmin=0
ShowAutoRuns=0
TrayTimeOut=20
ShowTrayAdmin=0
UseWinLogonDesk=1
NoConvAdmin=1
NoConvUser=1
DefHideSuRun=0
[User0]
Name=User
IsLocalUser=1
NoRunSetup=1
RestrictApps=1
InstallDevs=0
UserTSA=0
HideFromUser=0
ReqPw4Setup=0
StoreUsrPW=1
[WhiteList0]
0=""C:\Program Files (x86)\ERUNT\ERUNT.EXE""
1="C:\WINDOWS\SuRun.exe"
2=""C:\Program Files (x86)\ERUNT\AUTOBACK.EXE" C:\WINDOWS\ERDNT\#Date# /noconfirmdelete /noprogresswindow /days:14"
[WhiteListFlags0]
0=35
1=35
2=35

Here is my v1.2.1.0 settings:

[SuRun]
Version=1.2.1.0
BlurDesk=0
FadeDesk=0
SavePW=1
UseCancelTimeOut=0
CancelTimeOut=40
ShowCancelTimeOut=0
PwTimeOut=0
AdminNoPassWarn=4
CtrlAsAdmin=0
CmdAsAdmin=0
ExpAsAdmin=0
RestartAsAdmin=0
StartAsAdmin=0
HideExpertSettings=0
UseIShExHook=1
UseIATHook=1
TestReqAdmin=0
ShowAutoRuns=0
TrayTimeOut=20
ShowTrayAdmin=0
UseWinLogonDesk=1
NoConvAdmin=1
NoConvUser=1
DefHideSuRun=0
[User0]
Name=User
IsLocalUser=1
NoRunSetup=1
RestrictApps=1
InstallDevs=0
UserTSA=0
HideFromUser=0
ReqPw4Setup=0
StoreUsrPW=1
[WhiteList0]
0=""C:\Program Files (x86)\ERUNT\ERUNT.EXE""
1="C:\WINDOWS\SuRun.exe"
2=""C:\Program Files (x86)\ERUNT\AUTOBACK.EXE" C:\WINDOWS\ERDNT\#Date# /noconfirmdelete /noprogresswindow /days:14"
[WhiteListFlags0]
0=35
1=35
2=35
LeastPrivileges #43
Mitglied seit 06/2013 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Using VMware, I have now uninstalled and re-installed v1.2.1.0 and v1.2.1.1b8 five times each. v1.2.1.0 ran the shortcut file all five times at startup once I added the Windows password. In five tries, v1.2.1.1b8 never ran the shortcut file at startup even after adding the Windows password.
Kay (Administrator) #44
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
I could reproduce your issue in a (VirtualBox-) VM. :-)

If I start a link to "C:\Program Files (x86)\ERUNT\AUTOBACK.EXE" [...] from C:\Users\USERNAME\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup\AUTOBACK.lnk, SuRun misses to elevate it.

I don't know why this works on my real system.
I just can guess that Explorer starts it's "AutoRuns" before SuRun get's a chance to hook Explorer.
I changed SuRun's Hooks in v1.2.1.1, so this could be the cause for the difference between 1.2.1.0 and 1.2.1.1.

But if I start a link to C:\Windows\SuRun.exe "C:\Program Files (x86)\ERUNT\AUTOBACK.EXE" [...], SuRun elevates AutoBack.exe as it should.

So you need to prepend the command line with C:\Windows\SuRun.exe in SuRun 1.2.1.1.

Prepending any command line with C:\Windows\SuRun.exe should always work, because this does not depend on any hooks.
fraschi #45
Mitglied seit 10/2010 · 33 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hallo Kay,

ich habe solche ähnlichen Timing-Geschichten hier auf meinem neuen Win7-64-bit Notebook auch schon erlebt, dass Programme, die über irgendeinen der Autostart-Mechanismen gestartet wurden, nicht immer mit erhöhten Rechten liefen, obwohl ich in SuRun eingestellt hatte, dass sie immer und ohne Nachfragen mit erhöhten Rechten gestartet werden sollen. Bei einem voll gestarteten System funktionierte jeder anschließende (manuelle) Aufruf aber wie gewünscht mit erhöhten Rechten.

Ich nahm an, dass beim PC-Start diese Programme mitunter eben VOR SuRun gestartet wurden, so dass SuRun noch gar keine Chance hatte, die Rechte entsprechend zu erhöhen.

Als Workaround habe ich diese drei, vier Programme, die ich auch nicht wirklich gleich sofort nach dem Start brauche, entweder über die Aufgabenplanung bzw. über Start-Delay für einige Minuten nach der User-Anmeldung verzögert. Seitdem laufen sie auch zuverlässig immer mit erhöhten Rechten.

Herzliche Grüße
Franklin
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Seite:  vorherige  1  2  3  4  nächste 
Gehe zu Forum
Nicht angemeldet. · Kennwort vergessen · Registrieren
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Seite erstellt in 165,2 ms (114,8 ms) · 140 Datenbankabfragen in 28 ms
Aktuelle Zeit: 01.05.2017, 08:18:05 (UTC +02:00)