Forum: SuRun Fragen/Antworten RSS
Antwort merken ist ausgegraut
Tobias Schneider #1
Mitglied seit 03/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: Antwort merken ist ausgegraut
Habe Win7 32 bit und die neueste Surun so weit ich weiß.
Leider habe ich verschiedene Programme auf dem Rechner wie Eset oder RegRun, die nicht automatisch
erhöht gestartet werden, obwohl ich meines Wissens Surun so konfiguriert habe!?

Wie kommt das, was muss ich machen?

Problem ist:
Starte ich eines der Programme, so kann ich es erhöht starten, wenn ich das popup bestätige, aber das Feld
"das Surun sich die Entscheidung merkt und demnächst automatisch erhöht startet" ist ausgegraut :(

Ich bin als Nicht-Admin angemeldet.

danke
Kay (Administrator) #2
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Dafür kann es zwei Gründe geben:
  • "Benutzer darf SuRun Einstellungen verändern" ist nicht aktiv
  • SuRun's Hooks sind beide aus ("Direkt in Programme einhängen, die andere Programme ausführen." und "Programmstarts der Windows Benutzeroberfläche filtern")
Tobias Schneider #3
Mitglied seit 03/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Dann habe ich ein Problem,

denn alle drei Bedingungen waren und sind bei mir erfüllt. Das ist merkwürdig ;(

Vielleicht muss ich doch, mal unter dem Admin Acc Surun de-/neuinstallieren nach einem Export der Regeln.
Und sehen, was passiert. Sollte das Problem noch immer da sein, das Ganze dann mal ohne dem Import der exportierten Werte.

Aber, wenn Du sagst, es kann nur diese drei Gründe geben... ?=!?


Ich danke Dir auf jeden Fall für dieses super tool.
Neben, Letmetype (Clasholm) und TotalCommander mit auf dem Podest :)
Kay (Administrator) #4
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hallo Tobias,

Zitat von Tobias Schneider:
denn alle drei Bedingungen waren und sind bei mir erfüllt.

Das ist mehrdeutig.

Du musst auf jeden Fall "Benutzer darf SuRun Einstellungen verändern" aktiv haben.
Dann ist "Für dieses Programm nicht mehr fragen" aktivierbar.
Du musst auch noch mindestens eine der Optionen "Direkt in Programme einhängen, die andere Programme ausführen." und "Programmstarts der Windows Benutzeroberfläche filtern" aktiviert haben.
Dann sollte "Dieses Prog. immer autom. als Administrator starten" auch aktivierbar sein.

Gruß

Kay
Tobias Schneider #5
Mitglied seit 03/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hatte ich verstanden Kay,

und tut mir leid, dass ich es nicht erwähnt hatte, aber der grossteil meiner Programme funktioniert genau so, wie Du es beschreibst. Also, SR bietet die Option des Merkens an und tut dieses auch.

ABER bei ein paar Programmen, ist genau diese Option dennoch ausgegraut. Das wundert mich.
Kay (Administrator) #6
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Ich habe in einer VM mal Eset NOD32 AV und RegRun als Testversionen installiert. ESET Smart Security stürzte direkt bei der Installation (in einem nackten Win7 x32 ohne SuRun) ab, deshalb "nur" NOD32 AV.

SuRun läuft mit Standard-Einstellungen.
"Ersetze Windows 'Ausführen als...' durch SuRuns 'Ausführen als...'" ist allerdings aktiv. (warum eigentlich...?)

Nach einigen Schwierigkeiten mit RegRun, das SuRun's Autostarts und das Abschalten der automatischen Benutzeranmeldung an Windows blockierte, startet RegRun bei einem eingeschränkten Benutzer unter Win7 x32 einwandfrei automagisch aus dem Startmenü mit gehobenen Rechten:
[Bild: http://forum.kay-bruns.de/pic/RegRun.jpg]

Warum das bei Dir nicht geht, weiß ich nicht.
Hab ich da was übersehen?

Wenn Eset gehobene Rechte braucht, springt SuRun auch dazwischen:
[Bild: http://forum.kay-bruns.de/pic/Eset.jpg]

Ist "Ersetze Windows 'Ausführen als...' durch SuRuns 'Ausführen als...'" aus, meldet sich UAC und will ein Admin-Kennwort. Das sollte auch so sein.

Wenn Du Egui immer mit gehobenen Rechten starten willst, musst Du unter Win7 den Autostart in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run so verändern:
C:\Windows\SuRun.exe "C:\Program Files\ESET\ESET NOD32 Antivirus\egui.exe" /hide /waitservice
Allerdings schützt Eset den Wert vor Veränderungen, deshalb würde ich SuRun's "Ausführen als" aktivieren.
Tobias Schneider #7
Mitglied seit 03/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Kay,

das ist eine sehr ausführliche Antwort und ich finde es toll, dass Du Dir die Zeit dafür genommen hast!


Dennoch stehe ich auf dem Schlauch, denn Du siehst ja selber in Deinem letzten Screenshot, dass
das 1. Feld "Kennwort speichern" ausgegraut ist.

So ist es bei mir ja auch und ich kann es einfach nicht aktivieren.
Darum ging es mir, dass halt dieses Surun Popup nicht jedesmal bestätigen muss, sondern,
dass es halt automatisch passiert und ich nichts mitbekomme.

Aber Du hast ja geschrieben, dass ich dieses umgehen kann, in dem ich den 1. Aufruf durch das Windowssystem der Tools Eset AV und Regrun schon mit gehobenen Rechte ermögliche.

Mal sehen, ob das hilft. Ich danke Dir!
Kay (Administrator) #8
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1462 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Aachsoo: Du meintest schon immer "Ausführen als...".

Da unterstützt SuRun immer noch kein "nicht mehr fragen".

Das Kennwort ist ausgegraut, weil Du selbst der Benutzer bist und SuRun das Kennwort kennt. Deshalb musst/kannst Du es auch nicht speichern.
Tobias Schneider #9
Mitglied seit 03/2011 · 21 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Ok,

dann weiß ich nun, dass es nicht an mir lag. Ok, ich habe die Materie nicht verstanden aber ich hätte es auch nicht besser machen können.


ich danke Dir für Deine Mühen und Zeit und für das super Surun!
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Gehe zu Forum
Nicht angemeldet. · Kennwort vergessen · Registrieren
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Seite erstellt in 149,5 ms (59,9 ms) · 93 Datenbankabfragen in 65 ms
Aktuelle Zeit: 28.04.2017, 19:58:11 (UTC +02:00)