Forum: SuRun Fragen/Antworten RSS
SuRun installiert - jetzt komplett ausgesperrt!
nix #1
Mitglied seit 04/2011 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: SuRun installiert - jetzt komplett ausgesperrt!
Ich habe SuRun als Administrator installiert, habe danach dann ein neues Admin Konto angelegt aber dabei vergessen dem Admin ein Passwort zu verpassen und danach das alte Adminkonto zu einem eingeschränkten Konto gemacht.

Das Gute ist: SuRun scheint zu funktionieren.
Das Schlechte ist: Leider habe ich jetzt keinen Zugriff auf das Administrator-Konto und kann mich auch nicht zu den SuRunners hinzufügen.
Im Grunde kann ich überhaupt nichts machen, denn um etwas machen zu können, müsste ich ja das Admin Passwort eingeben aber da dieser keines hat, kann ich auch keines eingeben.

Leider kann ich mich auch nicht einfach als Administrator anmelden, da Windows so eingestellt ist, dass man automatisch angemeldet wird, nur jetzt eben als eingeschränkter Benutzer der ja keine Rechte hat.

Super Sache....
nix #2
Mitglied seit 04/2011 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Ok, gottseidank hatte ich etwas Glück und der Computer hat mich nach einem Neustart den Benutzer auswählen lassen (obwohl das gar nicht so eingestellt ist....).
Somit konnte ich also auch dem Admin ein Passwort verpassen und somit sind die Probleme im oberen Beitrag auch gelöst.

Nachdem ich nun mal aber schon hier bin, hätte ich doch eine Frage zu dem Programm und wie es konkret funktioniert:
Ich habe bspw. eingestellt, dass die Datei regedt32.exe (der Registry Editor) immer als Administrator gestartet werden soll und das klappt auch, allerdings nur wenn man direkt auf die Datei doppelt klickt.
Gibt man hingegen im "Ausführen"-Feld regedit ein öffnet sich der Registry Editor im eingeschränkten Modus.
Und das obwohl ja der Befehl regedit ja genau diese Datei öffnet.
Kay (Administrator) #3
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Es ist anders herum: %windir%\system32\regedt32.exe startet %windir%\regedit.exe.

Du müsstest also c:\windows\regedit.exe in die Programmliste eintragen (lassen) oder nachdem Du Regedit mit eingeschränkten Rechten gestartet hast im System-Menü "Neustart als Administrator" wählen und in SuRun "Für dieses Programm nicht mehr fragen" und "Dieses Prog. immer autom. als Administrator starten" aktivieren und OK klicken.
nix #4
Mitglied seit 04/2011 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
"Neustart als Administrator" gibt's zwar bei regedit.exe nicht zur Auswahl aber aufgrund deiner Antwort ist mir wieder eingefallen, dass es ja - sinnigerweise - zwei Registry-Editoren gibt, oder zumindest ein und dasselbe Ding unter zwei verschiedenen Namen und in zwei versch. Ordnern....
Egal, danke also für diesen Hinweis.

Noch eine Frage:
Gibt's vllt. eine Möglichkeit den Explorer (oder lieber Arbeitsplatz) immer als Administrator zu starten?

Abgesehen davon sind mir Fehler aufgefallen:
Wenn ich bspw. den Programme-Ordner öffne (und zwar über den Umweg "Systemsteuerung als Administrator" aus dem Desktop-Kontextmenü) und dort einen neuen Ordner erstelle, wird mir der zunächst nicht angezeigt.
Selbst wenn ich "surun explorer here" im Kontextmenü des jew. Ordners öffne und dann dort einen neuen Ordner erstelle wird nichts angezeigt.
Erst nach einer Ab- und Wiederanmeldung werden diese Ordner sichtbar.
Dasselbe gilt für das Löschen von Ordnern:
Ich markiere also bspw. die oben erstellten Ordner, wähle im Kontextmenü "Löschen" aus und nichts scheint zu passieren.
Erst nach einer Neuanmeldung sieht man, dass die Ordner entfernt wurden....
Kay (Administrator) #5
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Zitat von nix:
"Neustart als Administrator" gibt's zwar bei regedit.exe nicht zur Auswahl

Das kann man in den SuRun-Einstellungen konfigurieren.

Zitat von nix:
Gibt's vllt. eine Möglichkeit den Explorer (oder lieber Arbeitsplatz) immer als Administrator zu starten?

SuRun bietet bei Explorer normaler Weise die "Neustart als Administrator"-Option nicht an.
Wenn Du z.B. "C:\WINDOWS\explorer.exe *" in Deine Programmliste einträgst, wird Explorer immer mit gehobenen Rechten gestartet, auch Dein "Windows Desktop".

Mach das aber bitte nicht.
Explorer ist ein zu beliebtes Angriffsziel, um ihn immer administrativ zu starten.
Außerdem würde jedes Programm, das Explorer startet auch als Administrator laufen.

Zitat von nix:
Wenn ich bspw. den Programme-Ordner öffne (und zwar über den Umweg "Systemsteuerung als Administrator" aus dem Desktop-Kontextmenü) und dort einen neuen Ordner erstelle, wird mir der zunächst nicht angezeigt.

Das ist ein bekanntes Problem von Explorer. (hier im Forum schon mehrfach beschrieben)
Es tritt auch mit allen anderen SuRun-ähnlichen Programmen auch.

Du kannst <F5> drücken und siehst die Änderungen.
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Gehe zu Forum
Nicht angemeldet. · Kennwort vergessen · Registrieren
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Seite erstellt in 93,2 ms (47,9 ms) · 65 Datenbankabfragen in 19,6 ms
Aktuelle Zeit: 17.12.2017, 20:43:06 (UTC +01:00)