Forum: SuRun English speaking RSS
Problems with SuRun
Page:  1  2  next 
doveman (Guest) #1
No profile available.
Link to this post
Subject: Problems with SuRun
I'm generally very happy with SuRun (thank you), but I'm having a few problems.

1) I can't run gpedit.msc. Well I can, but I get a Group Policy Error and it opens in some sort of locked mode. Clicking "Restart as administrator" in the title bar doesn't work.

2) If I go to a webpage and open a zipfile containing an nzb file, when it opens in WinRAR and I click on the nzb file, it displays it as a text file rather than opening it in my Usenet program. If I "Restart as administrator" WinRAR, it then works as it should, but I have to do this each time. I've tried adding WinRAR to SuRun's program list, but it doesn't work as it seems to treat each instance of it as a different program, because it opens with a command like this:
""C:\Program Files\WinRAR\WinRAR.exe" "C:\Documents and Settings\Main\Local Settings\Application Data\Opera\Opera\temporary_downloads\nzb1.zip"".

3) Even though "Require user password for SuRun settings" is unticked, it still asks for my password every time I open it.
doveman (Guest) #2
No profile available.
Link to this post
Found another!

4) "Allow SuRun users to set (and show) the system time" doesn't seem to have any effect and I get "You do not have the proper privilege level" when clicking on the time. Whether this option is ticked or not, I can "Restart as administrator" and the time/date window opens OK.
Kay (Administrator) #3
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
Let me get straight to your points:

1) This is a known limitation. (Although it's not listed in the Readme). You need to use "SuRun /RunAs gpedit.msc"

2) I would not recommend to always start WinRAR with administrative rights! But  of course SuRun can do that, if you use wild cards in the command line: ""C:\Program Files\WinRAR\WinRAR.exe" *"

3) This usually works. Did you uncheck "The user can change SuRun settings"? Or did you check "Users must enter their password" on the first settings page?

4) You need to log off to apply changes in this setting.
doveman (Guest) #4
No profile available.
Link to this post
Thanks. I think you've dealt with all the points nicely.

1) I still get the same problem, unless I use the Administrator credentials rather than my normal limited user's in the SuRun popup. Could I have set something in gpedit previously that makes it only accessible to the Admin account in this way?

2) That's probably good advice not to always start WinRAR with admin rights. I do find it incredibly annoying to have to keep restarting it though, just so that I can click on files in the archive and have them open with the associated program rather than view them as text, so I'll have to make a decision one way or the other.

3) "The user can change SuRun settings" is checked. "Users must enter their password" is also checked but I thought this was a necessary security measure to prevent rogue programs running something as Admin and just auto-clicking OK on the SuRun popup when it appears. I can put up with entering my password to edit the settings if this is the only way to preserve the password protection when starting programs as Admin.

4) I'm sure that's the answer. I don't log off very often, so once I get a chance to close all the programs I'm running, I'll try that.
Kay (Administrator) #5
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
1) This works for me on all my systems. You should see a red smiley symbol with a yellow exclamation mark in the system notification area if gpedit runs as "real administrator".

3) "Users must enter their password" is an option to prevent others from starting something with SuRun when your system is unattended and unlocked. This means that you also need to enter the password for changing SuRun settings. No program can (by intention) "Auto click" OK in SuRun's dialogs. These dialogs run on a separate desktop that the logged on user (and thus his programs) has no access to.
doveman (Guest) #6
No profile available.
Link to this post
1) As I said, I think I must have set something somewhere as it just doesn't work for me.

3) Thanks for the explanation. I'm less paranoid about something auto-clicking OK now :)
doveman (Guest) #7
No profile available.
Link to this post
I found another little problem. I can't modify my Network Connections properties under a LUA, even with SuRun.

The window doesn't show "Restart as" and doing "SuRun /Runas ncpa.cpl" doesn't work either.

I wonder if this could be implemented in the same way as SuRun's Advanced options to allow SuRunners to change the system time and modify the Power options?
Kay (Administrator) #8
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
I successfully use "surun ncapa.cpl" all the time. Just tried "surun /runas ncpa.cpl" and that works too here.

The "Restart as administrator" is not available, because ncpa.cpl opens a new window in explorer.exe that runs as shell. This would restart the shell as admin.
doveman (Guest) #9
No profile available.
Link to this post
Well if I use "surun ncapa.cpl" after OK'ing the SuRun window, nothing appears!

If I use "surun /runas ncpa.cpl" after entering my password the Network Connections window does open, but when I open any of the connections' properties pages, I get "Some of the controls on this property page are disabled because you do not have sufficient privileges to access or change them".

In Group Policy, all the settings under "User Configuration\Administrative Templates\Network\Network Connections" are set to Not Configured, so there doesn't appear to be anything there causing the problem.
Kay (Administrator) #10
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
All these things usually just work.

I did not ask earlier:
What OS do you use?
Are you a domain member?
Do you have a HIPS installed?
What SuRun version do you use?
doveman (Guest) #11
No profile available.
Link to this post
Nothing usually just works for me :)

To answer your questions:
XP Pro SP3

Not a domain member

The other security software I run is Sunbelt Personal firewall 4.6 (which has Application Behaviour Blocking) and SpyShelter Personal Free 4.55

SuRun v1.2.0.8
Kay (Administrator) #12
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
I guess that the behavior blocking in Sunbelt keeps SuRun from doing it's work.

If you pull the network plug and uninstall both HIPS, does SuRun work as it should?
doveman (Guest) #13
No profile available.
Link to this post
Well I can disable the behaviour blocking in Sunbelt without uninstalling it, and disable SpyShelter protection as well.

I still have the same problem with Network Connections.
doveman (Guest) #14
No profile available.
Link to this post
Another bug I've found is that when deleting items in a SuRun Explorer, the folder doesn't refresh automatically, so the files that I've deleted are still shown until I press F5.
Kay (Administrator) #15
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
The F5 Bug is known for long.
This is by a "fault" design in Explorer.
It was never meant to run on one desktop with two "different" logons.
Try the Windows "runas" with Explorer and you'll need to press F5 here too.

I'll try the sunbelt in a VM...
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Page:  1  2  next 
Go to forum
Not logged in. · Lost password · Register
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 72.3 ms (38.2 ms) · 107 database queries in 21.5 ms
Current time: 2019-12-10, 15:03:45 (UTC +01:00)