Forum: SuRun Fragen/Antworten RSS
[Problem gelöst] Links im Startmenu mit Admin-Rechte (dank SuRun) ausführen?
PrAdiminix9 #1
Member since Apr 2010 · 5 posts
Group memberships: Mitglieder
Show profile · Link to this post
Subject: [Problem gelöst] Links im Startmenu mit Admin-Rechte (dank SuRun) ausführen?
Hallöchen,

weiss jemand wie ich Links im Startmenu mit Admin-Rechte (dank SuRun) ausführen kann?

Hintergrund:
Auf mein Laptop ist Win XP SP3 ist SuRun v.1.2.0.8 installiert.
Die SuRun-Programm-Filter ist abgeschaltet, weil ZoneAlarm meckert, dass Firefox,... suspectes Verhalten habe, wenn sie SuRun.dll /exe ausführen möchten.

Wenn ich mein Defrag-Programm als über das Startmenu als normaler User starte, und dann oben im Titelleiste rechtsklicke und Neustart als Administrator auswähle, dann kommt stürtz mein defrag-prog manchmal ab.
Workaround: Ordner im Startmenu auswählen, recht-klick Explorer wählen, im Explorer rechtsklick 'SuRun Explorer hier' auswählen, Link im SuRun-Explorer auswählen. Das ist mir etwa mühsehlig. Geht das einfacher?

Vielen Dank für die Hilfe!

Einen schönen und friedvollen Tag,
PrAdiminix9
This post was edited on 2010-04-30, 02:04 by PrAdiminix9.
Mik.c.OS #2
User title: scriptkiddy :D
Member since Dec 2007 · 338 posts · Location: Europa
Group memberships: Mitglieder
Show profile · Link to this post
erstell oder ändere deine vorhandene verknüpfung,
indem du surun vor dem befehl setzt...
[0001 0110]
Mik.c.OS Shell Extensions for SuRun (rev3.1) [2010-10-27] ("The Ugly One" :D )
PrAdiminix9 #3
Member since Apr 2010 · 5 posts
Group memberships: Mitglieder
Show profile · Link to this post
Subject: Problem gelöst.
Hi Mi.c.OS,

danke für Deine Antwort.
Für einzelne Programme ist es eine pragmatische Lösung - finde ich gut.
Für um die 50 Systemprogramme alle Verknüpfungen umzuschreiben ist nicht unbedingt lustig.
Da wäre es mir ein Registy-Hack lieber, wo ich via Rechts-Klick dann SuRun aufrufen kann

Habe das Problem endlich gefunden:
Es gibt (mindestens) zweierlei Verknüpfungen im Windows explorer:
Eine "große" was das Installationsprogramm vom Macrium Reflect selbst erstellt. Diese kann ich nicht selbst ändern - ist ausgegraut im Eigenschaftsfenster. Diese "große" Verknüpfung bei mir 2485 Bytes groß. Diese Art von Verknüpfung löst die Verknüpfung nicht auf und zeigt auch nicht der Kontextmenü an vom Eintrag im
HKEY_CLASSES_ROOT\Exefile\shell\SuRun\command

Die "kleine" Verknüpfungen, die man selbst über Kontextmenü "Verknüpfung erstellen" selbst erstellen und ändern kann. Für Macrium Reflect ist diese "kleine" Verknüpfung bei mir 680 Bytes groß. Diese Art von Verknüpfung löst schon die Verknüpfung auf und zeigt auch doch der Kontextmenü an vom Eintrag im
HKEY_CLASSES_ROOT\Exefile\shell\SuRun\command

Beide Arten von Verknüpfungen zeigen im Kontextmenü einen Eintrag an im
HKEY_CLASSES_ROOT\lnkfile\shell\SuRunNonWorking1\command
sowie
HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\SuRunNonWorking2\command
Jedoch lassen sich damit keiner der beiden Arten von Verknüpfungen starten, sondern gibt die SuRun die Fehlermeldung aus: 'Fehler! [Newline] "C:\...\reflect.lnk" konnte nicht gestartet werden.'
Wenn es unter lnkfile\shell  sowie  AllFilesystemObjects\shell  KEIN SuRun Eintrag gibt, dann löst Windows die Verknüpfung selbst auf, kommt darauf dass in diesen spezifischen Fall das Ziel eine Exe-Datei ist, und such unter
HKEY_CLASSES_ROOT\Exefile\shell\SuRun\command
Wird dort fündig und führt es auch aus, und es funktioniert wie gewünscht.

Mir scheint es, dass Windows die beiden Arten von Verknüpfungen unterschiedlich auflösen bezogen auf den Kontextmenü. Beim Doppelklick haben die beiden Arten von Verknüpfungen jedoch die gleiche (end-)Wirkung.

Die Work-around ist wohl alle "große" Verknüpfungen mit "kleine" auszuwechseln.
Also Problem gelöst. :-D

[Nachtrag:]
Da ich mit diese zwei Workarounds nicht wirklich zufrieden war, bei den Mengen von Verknüpfungen zu ändern, habe ich weiterhin nach eine Lösung gesucht.
Bessere Lösung (für mich jedenfalls):
Im Registry einen Eintrag für lnkfile machen, wo das cmd.exe die Verknüpfung auflöst.
Auf de Kommandozeile sieht es so aus:

C:\WINDOWS\SuRun.exe  C:\WINDOWS\system32\cmd.exe   /S /K  ""C:\Dokumente un
d Einstellungen\username\Startmenü\Programme\SystemUtils\Macrium (Reflect)\Refle
ct\Reflect.lnk""

Im Registry mit eben mehr Escape-Zeichen:
<<<<<<<<<<<<<<<< Datei-Beginn nach dieser Zeile  >>>>>>>>>>>>>>>>>>>>>>>>>
REGEDIT4

[HKEY_CLASSES_ROOT\lnkfile\shell]

[HKEY_CLASSES_ROOT\lnkfile\shell\SuRun_lnk]
@="Starte als Administrator (SuRun) [lnkfile]"

[HKEY_CLASSES_ROOT\lnkfile\shell\SuRun_lnk\command]
@="C:\\WINDOWS\\SuRun.exe  C:\\WINDOWS\\system32\\cmd.exe   /S /C  \"\"%1\"\""

<<<<<<<<<<<<<<<<  Datei-Ende vor dieser Zeile  >>>>>>>>>>>>>>>>>>>>>>>>>

Damit habe ich für der "große"-Verknüpfungstyp (siehe oben) endlich einen Eintrag für SuRun, der so auch funktioniert. Zwar zum Preis, dass für der  "kleine"-Verknüpfungstyp (siehe oben) zwar zwei Einträge für SuRun gibt.
Zwar kann man den Schlüssel [HKEY_CLASSES_ROOT\lnkfile\shell\SuRun]  nennen, dann verschwindet abar auch der (standardmäßige Eintrag von SuRun-Installation) im exefile. Dass könnte zu Probleme führen bei SuRuns Programmliste. Damit ich für keinen anderen da ein Problemloch aufreise, ist mir diese Art und Weise lieber - jedenfalls für das Jetzt.

P.S.
Wer das Utility Unlocker http://ccollomb.free.fr/unlocker/ einsetzt, um gesperrte Dateien zu "befreien", wird merken, dass unlocker.exe  schon einige Privilegien braucht, was ich aus Sicherheitsgründen wegen Viren,... nicht ständig haben möchte.

Klar kann SuRun da helfen:
<<<<<<<<<<<<<<<< Datei-Beginn nach dieser Zeile  >>>>>>>>>>>>>>>>>>>>>>>>>
REGEDIT4

[HKEY_CLASSES_ROOT\AllFilesystemObjects\shell]

[HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\UnlockerSuRun]
@="Unlocker als Administrator (SuRun)"

[HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\UnlockerSuRun\command]
@="C:\\WINDOWS\\SuRun.exe  C:\\Programme\\Unlocker\\unlocker.exe %1"

<<<<<<<<<<<<<<<<  Datei-Ende vor dieser Zeile  >>>>>>>>>>>>>>>>>>>>>>>>>
This post was edited 3 times, last on 2010-04-30, 12:17 by PrAdiminix9.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Not logged in. · Lost password · Register
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 49.1 ms (23.2 ms) · 51 database queries in 10.6 ms
Current time: 2019-12-13, 12:30:05 (UTC +01:00)