Forum: SuRun English speaking RSS
Problem with ERUNT
autostart in Startup
Joaquin (Guest) #1
No profile available.
Link to this post
Subject: Problem with ERUNT
After installing the latest version of Avira Antivir, informing you of the status of the account (administrator), I realized the risks that, unlike Ubuntu, we have running Windows as usual mode. I found. Surun on the web which I find a good solution to this problem in Windows.

But I have a problem with ERUNT that I can not solve. The program has a piece (ERUNT AutoBackup) to back up the registry when the system starts, placed in the Startup folder. I get the following error:
         Unable to create folder C: \ WINDOWS \ ERDNT \ AutoBackup \ 19/04/2010
 

I set the tab "SuRouners group" including
         C: \ Program Files \ ERUNT \ AUTOBACK.EXE
         C: \ Program Files \ ERUNT \ ERUNT.EXE
both with
         Automatically start this program with elevated rights
(Also with "never ask for a Password")
         Start the program with elevated rights automagically
 
I can not solve the problem.

I appreciate your help

Thanks
Cosmo #2
Member since Mar 2008 · 451 posts
Group memberships: Mitglieder
Show profile · Link to this post
I don't think this is a Surun-problem and not a problem of elevated permissions, but with the naming of the folder 19/04/2010.

Generally the character / is not allowed in Windows as part of a file- / folder - name. And Autoback does for me (on a German Windows) create a name in the scheme 19.04.2010. You should check this.
Thomas
Joaquin (Guest) #3
No profile available.
Link to this post
Subject: ERUNT problem
Thanks for your kind and quick response. I enclose information that could be helpful in resolving the issue:

1) I use Windows XP SP3.

2) The ERUNT software comprises at least two programs ERUNT.EXE and AUTOBACK.EXE. Software documentation indicates that
------“AUTOBACK is a command line utility

3) I uninstalled, cleaned program traces and reinstalled ERUNT. This time, as an alternative, I've installed in a directory created by me (C:\Programs)

4) Under the Windows Administrator account both programs are running without any problems.

5) Under the limited user account must be included in Surun (surunners group) with the options:
------Automatically start this program with elevated rights and never ask for a Password
------Start the program with elevated rights automagically
but only succeeds ERUNT.EXE

6) The program documentation
http://www.larshederer.homepage.t-online.de/erunt/erunt.txt
reports the following:
------“Note: To ensure proper operation of ERUNT, you should be logged in as a system administrator.”
The backup can be outside the WINDOWS system folder, but not recommended for the following reason
------“You can also simply leave the default, which is a folder named ERDNT inside your Windows folder, the advantage being that you have access to this folder from the Windows Recovery Console in case Windows does not boot anymore

7) To confirm your suggestion I created a file ERUNT.ini amending syntax to yyy.mm.dd, both in the user account as the Administrator. Currently the message in the user's account of surunners group is as follows
------“Unable to create folder C:\WINDOWS\ERDNT\AutoBackup\2010.04.20

8) I tried to run the program AUTOBACK.EXE in the user account under all conditions that have occurred to me. In my opinion the problem is not parameters, but access to directories. There are basically two situations:
a) In the system directory with the command:
------C:\Programs\ERUNT\AUTOBACK.EXE %SystemRoot%\ERDNT\AutoBackup\#Date# /noprogresswindow
the result is
------“Unable to create folder C:\WINDOWS\ERDNT\AutoBackup\2010.04.21
b) In the alternative directory of the program itself, with the command
------C:\Programs\ERUNT\AUTOBACK.EXE C:\Programs\ERUNT\ERDNT\#Date# /noprogresswindow
the result is
------“Error saving file. C:\Programs\ERDNT\AutoBackup\2010.04.20_14:21\SECURITY!. Continue with the next file? (RegCreateKeyEx 5 - Access denied)

9) Before I write to you I made several Internet searches for a solution.
With the chain:
------Unable to create folder \ERDNT\AutoBackup
there are several entries. Among the top 20, most belong to the underworld of infectious panic. The closest to the problem seem related to the UAC of Windows Vista, but provide no solution.
http://forum.piriform.com/lofiversion/index.php/t16443.html
http://www.annoyances.org/exec/forum/winvista/t1256396262
http://www.sevenforums.com/crashes-debugging/48284-bsod-im…
And with the string
------ Error saving file \erdnt\autobackup security
there are several comments. For example, this:
http://forums.techguy.org/all-other-software/888899-solved…
whose successful outcome I could not reproduce despite uninstalling, clean traces and reinstalling.

Thanks for your interest and your help
Cosmo #4
Member since Mar 2008 · 451 posts
Group memberships: Mitglieder
Show profile · Link to this post
I use ERUNT / AUTOBACK since years on XP SP3, executing AUTOBACK daily without problems. So I cannot confirm the behavior you described.

Some ideas:
Rename the file erunt.ini, so that it does not get recognized. Maybe there is a problem with your settings.

Regarding steps 7 & 8: You mean executing in the limited account as surunner? Without that it cannot work. Check the surun-tray icon if it gets red, indicating that the current process gets executed with admin privileges. If it does not get red you run the process with limited rights, and than it cannot work.

Try to add the Parameter /noconfirmdelete. This parameter is in the command line (if you let the installer create a startup-link for AUTOBACK) by default.

There is something odd with the parameter #Date# Why is the result in one case 2020.04.21, but in the other case 2010.04.21_14:21? There is a inconsistency between what you report here and what you get; #date# does not create a time-value in the folder name. And again: There is a character, which is not allowed in Windows for file / folder names ( : ). Probably this comes from your ini-file and will disappear after renaming the ini-file.
Thomas
Joaquin (Guest) #5
No profile available.
Link to this post
I've done so many tests that I'm finally confused. Thanks for your suggestions, I'm glad to know that you use ERUNT smoothly. Let's see ..

1) My configuration "SuRunners group" is this:
------ C: \ Program Files \ ERUNT \ AUTOBACK.EXE
------ C: \ Program Files \ ERUNT \ ERUNT.EXE
both with
------ Automatically start this program with elevated rights and never ask for a Password
------ Start the program with elevated rights automagically

2) My configuration "ERUNT AutoBackup" in Startup is:
C:\Programs\ERUNT\AUTOBACK.EXE % SystemRoot%\ERDNT\AutoBackup\#Date# / noprogresswindow /noconfirmdelete.
I get always the message "Unable to create folder ..."

3) I deleted ERUNT.ini. Some times I have added the option #Time# to differentiate folder creation. Once I login session in “administrator account” to verify “ERUNT Autobackup” boot without problems.

4) The program ERUNT.EXE runs smoothly directly. SuRun become red.

5) Direct access to AUTOBACK.EXE in Startup succeeds by "Start as administrator", after logging. However, executed directly, not working or at boot, or after logon. SuRun remain green.

I'm not sure if I explained everything so well, but anyway I hope your help. How do you set Surun for ERUNT?

Thanks
Cosmo #6
Member since Mar 2008 · 451 posts
Group memberships: Mitglieder
Show profile · Link to this post
This one I do not Understand what you mean:
Quote by Joaquin:
5) Direct access to AUTOBACK.EXE in Startup succeeds by "Start as administrator", after logging. However, executed directly, not working or at boot, or after logon. SuRun remain green.

What is the difference between "direct access" and "executed directly"? Without knowing that I do not see, why in the first case it does work (Surun gets red) and in the other case not. And it is clear, with a green surun icon Autoback does not get started elevated and out of this it cannot create the needed folder.
Thomas
Joaquin (Guest) #7
No profile available.
Link to this post
I apologize for my poor English. “Erunt AutoBackup” is a shortcut (“acceso directo” in spanish Windows), located in the Startup folder, to AUTOBACK.EXE, which runs with various options. This shortcut run with already commented error during the boot. The bug is reproduced if run (click left button) after login. No error occurs if you run through "Start as administrator" (right click). No problem during boot if you log into the Administrator account. Running ERUNT.EXE into "limited user" account occurs without problems.

My conclusions:
# My program's configuration of ERUNT and "ERUNT AutoBackup" are correct.
# My SuRun configuration to run ERUNT.EXE with elevated rights is correct.
# My SuRun configuration to run  AUTOBACK.EXE with elevated rights is not correct.

Question:
How have you configured your SuRun to allow "ERUNT AutoBackup" run in Startup folder with elevated rights on the boot without problems? Will you tell me how you would configure each of the SuRun's tabs for the proper execution of "Erunt AutoBackup"?

Thanks
Cosmo #8
Member since Mar 2008 · 451 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post #6
Quote by Cosmo:
What is the difference between "direct access" and "executed directly"?
Still not answered and no idea, what you could mean with this. And most probably the point to find the culprit of your problem.
Thomas
Joaquin (Guest) #9
No profile available.
Link to this post
Microsoft translate “shortcut” for “acceso directo” (which I translate bad as “direct access”) in spanish version of Windows XP. So, point 5 of my post from yesterday at 21 h meant:
# “Erunt AutoBackup” (shortcut to AUTOBACK.EXE) at Startup folder do not work at boot or after login showing in both cases window's information “Unable to create ...”. But work perfectly if you right click over and run “start as administrator”.

You do not answer my very specific questions (how do you all Surun configured to run "Erunt Autobackup?). It seems that you look the problem from the beginning in a linguistic misunderstanding or my ERUNT settings, although something as obvious as its good performance in the “Administrator account” or "star as administrator" (also works with "run as .." .) in “user limited account”. IMHO the problem is Surun or my SuRun settings.

Thanks
Cosmo #10
Member since Mar 2008 · 451 posts
Group memberships: Mitglieder
Show profile · Link to this post
OK, now it's getting clearer.

With the last information and re-reading your post from yesterday evening I think, that in your surun-autoback-setting the parameters for autoback are missing.

Doing this should solve the problem:
Start Erunt Autobackup (from the shortcut) via "start as Administrator"; in the upcoming dialog activate both(!) check-boxes at the bottom, so that a matching entry in the surunner-settings gets created automatically. This should help.

(I do not answer your last question, because there are some special configurations / software settings from other software included, which will not match with your system and would initiate more questions than it would give solutions. But with the instruction in the previous paragraph you should come to the wanted result.)
Thomas
Joaquin (Guest) #11
No profile available.
Link to this post
Thank you very much. I followed your instructions. Now works perfectly

I reintroduced the INI file and the command #time# without altering its proper functioning.

Apparently, the problem is that the execution of command line utilities as AUTOBACK.EXE require the introduction into SuRun not only of the program as I did
------C:\ProgramFiles\ERUNT\AUTOBACK.EXE
but all the commands
------"C:\ProgramFiles\ERUNT\AUTOBACK.EXE" C:\WINDOWS\ERDNT\AutoBackup\#Date#_#Time# /noconfirmdelete /noprogresswindow

Additionally, to run on boot, only with the option
------Automatically start this program with elevated rights
which is obtained by default on activate both check-boxes at the bottom in the upcoming dialog,  does not get it to work. You have to check into the Surun options
-----Automatically start this program with elevated rights and never ask for a Password
Also you must check
------Start the program automagically with elevated rights

The program
------"C:\ProgramFiles\ERUNT\ERUNT.EXE
it is not required in Surun for execute "ERUNT AutoBackup", so I run it with "start as administrator" when necessary.

It might be good idea to place the tag [SOLVED] in the title of the thread and may be change the title also ("problems run commans line programs"?). Also, if you think fit, you could add some small technical explanation, wich may be of interest to readers of the forum. I have not been able to find an English manual wich explain these SuRun's requirements, in those case I probably would not have needed your help.

Thanks
Cosmo #12
Member since Mar 2008 · 451 posts
Group memberships: Mitglieder
Show profile · Link to this post
Thank you for the feed-back.
Thomas
discs #13
Member since Mar 2010 · 10 posts
Group memberships: Mitglieder
Show profile · Link to this post
Thanks for the solution.  I was having the same problem - and, yes, I now realise the solution was a simple one.  Thank you again for Surun.  I never, because I found it too inconvenient, used a Limited User Account before discovering Surun! - and now I use a LUA all the time.
RonCam #14
Member since Jan 2011 · 1 post · Location: Funchal
Group memberships: Mitglieder
Show profile · Link to this post
This thread is old, but I think there is new information here, to help anyone coming across it in a search:

I have just resolved the problem in a different way.  ERUnt was not finding the target directory in a Limited User Account for the daily Registry backups.  I think my addition to the thread is new information because I scanned through the posts in this thread, and failed to see the term All Users.  This solution is independent of having SuRUN installed, but instead a problem of running ERUnt with Limited Accounts. 

The problem of not seeing the directory stopped, when I directed the output of ERUnt to a folder in this user profile.  On my systems, this is not the conventional location, but appears in the upper area (Launcher?) on the Windows Start Menu, in a folder/directory named Last 4 Registries (RUN erdNT.exe). The last part is a reminder for what to do, when the directories for each of the last four (in my case) backups is displayed. 

The important thing is that when this folder was made to be present in the All Users profile, the directory began to accumulate the backups, no matter what type of User (Admin, Limited, etc.) was opened on the first boot of the day.  Before that, there was just an error message, with an abort, if the first run of the day was opened in other than Administrator.  And, the daily backup shorcut has to be pointed to this directory.
The author has attached one file to this post:
ERUnt on Menu -temp.png | Save   6.8 kBytes
Image
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Not logged in. · Lost password · Register
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 85.4 ms (65.2 ms) · 105 database queries in 8.4 ms
Current time: 2019-07-17, 01:16:58 (UTC +02:00)