Forum: SuRun Zickende Software RSS
Problem mit SuRun.exe und Sandboxie
(gelöst)
Amm0n #1
Mitglied seit 03/2008 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: Problem mit SuRun.exe und Sandboxie
Hallo Leute,
als erstes mal ein dickes Lob an den Entwickler von SuRun!

Leider gibt es aber ein Problem mit dem Programm Sandboxie. Normalerweise starte ich meinen Browser und meinen Mailclienten (FF un Tb) immer in einer Sandbox. Seit ich SuRun installiert habe, startet wenn ich die entsprechende Verknüpfung wähle aber zuerst die SuRun.exe und 2 Minuten später öffnet sich der Boxed FF oder Tb... Habe in den SuRun-Einstellungen nichts konfiguriert, da Sandboxie oder Firefox und Thunderbird keinerlei Adminrechte benötigen um einwandfrei als eingeschränkter Benutzer zu funktionieren. Wie kann es sein das SuRun.exe sich automatisch an die Start.exe von Sandboxie hängt ohne das ich etwas entsprechendes eingestellt habe? Ich habe schon alles mögliche ausprobiert, aber ich bekomme FF und Tb nicht mehr ohne die Verzögerung von 2 Min. durch SuRun.exe zum laufen... :/

Meine Verknüpfungen: Ziel: C:\Programme\Sandboxie\Start.exe C:\Programme\Mozilla Firefox\firefox.exe
                             Ausführen in: C:\Programme\Sandboxie

Und das gleiche nochmal mit Thunderbird.

Ohne Sandbox laufen beide Programme einwandfrei. In den Sandboxeinstellungen finde ich auch keine SuRun.exe.

Ich hoffe mir kann jemand bei dem Problem helfen.

Grüße

Amm0n
Kay (Administrator) #2
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1469 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hallo AmmOn,

Das SuRun startet ist normal.
Die Hooks, die versuchen das automatische Ausführen von Programmen zu regeln starten SuRun.
Warum dann aber 2min Pause ist... ?

Ich schau mir das morgen mal an :-)

Kay

EDIT: Vielleicht ein Schnelltip: Starte doch Sandboxie FF/TB mal "Als Administrator" und klicke dann "Abbrechen" und aktiviere vorher "Für dieses Programm nicht mehr fragen"... vielleicht hilft das.
Kay (Administrator) #3
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1469 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
...doch heute!

Ich habe den Fehler gefunden.

Sandboxie blockiert die Kommunikation zwischen SuRun und dem SuRun Dienst.
SuRun wartet min. 240s, ob es doch noch klappt und beendet sich dann.

Ich versuche das generisch zu lösen, aber nicht mehr heute.
Amm0n #4
Mitglied seit 03/2008 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Danke für die schnelle Antwort!
Dein Tip hat zwar nur zur Hälfte geklappt, aber immerhin. ;)
Ich bekomme die beiden Anwendungen leider nur als Administrator in der Sandbox ohne "Pause" zum laufen.
Wenn ich die Option: NIE mit erhöhten Rechten starten und nicht nachfragen wähle, startet immer die SuRun.exe in der Sandbox, wie von mir im ersten Thread beschrieben.

Wäre supi, wenn du dafür irgendwann noch ne Lösung finden würdest :)
Kay (Administrator) #5
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1469 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: Gelöst
Ich hab's:

In SandBoxie muss "Full Access" (Resource Access\File Access\Full Access)
für \Device\NamedPipe\SuperUserRun gesetzt werden, dann geht's.

In Sandboxie.Ini wäre das:
OpenPipePath=\Device\NamedPipe\SuperUserRun

Grüße,

Kay
Amm0n #6
Mitglied seit 03/2008 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
WOW!
Funktioniert! *froi*
Vielen Dank das du dir Zeit für mein Prob genommen hast! Das nenn ich mal Support :)
Dein Tool ist wirklich genial, erspart einem eine Menge Arbeit und Zeit.
Kay (Administrator) #7
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1469 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Zitat von Amm0n:
Vielen Dank das du dir Zeit für mein Prob genommen hast!

Nichts zu Danken!
"Dein" Problem haben sicher viele und sowas muss gelöst werden :-)
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Gehe zu Forum
Nicht angemeldet. · Kennwort vergessen · Registrieren
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Seite erstellt in 100,3 ms (47,7 ms) · 75 Datenbankabfragen in 20,9 ms
Aktuelle Zeit: 23.09.2017, 13:05:37 (UTC +02:00)