Forum: SuRun English speaking RSS
Error
Permissions
ParadigmShift #1
Member since Dec 2008 · 22 posts
Group memberships: Mitglieder
Show profile · Link to this post
Subject: Error
I just installed v1.2.0.8 on an XP Pro PC and nothing works.

"You may not have the appropriate permissions to access the item."

I checked and rechecked all the configurations and nothing is different from other installs on other PCs. I checked SRP (secpol.msc) and nothing is different there either. Something is blocking the programs in the whitelist. I have checked "User can only run programs with predefined elevated rights." The only thing different from my other PCs is this PC has two user accounts instead of one. It has John and Betty. I want both accounts to use SuRun but neither will work. I am on a domain as well, but I've never had any issues before. Thanks.
This post was edited on 2009-11-04, 19:18 by ParadigmShift.
Kay (Administrator) #2
User title: Weltverbesserer
Member since Nov 2007 · 1508 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
A main difference between 1.2.0.6 and 1.2.0.8 is that SuRun needs to store passwords for domain users.
This closes a vulnerability present in all v1.2 until 1.2.0.7.

Did you check "Hide SuRun from this user" for John and Betty?
If not, could you please post a screen shot of page 2 of SuRuns Settings (same as attached of your machine)?

(Just that I can check your settings in my VM mini domain.)
The author has attached one file to this post:
settings2.png | Save   31.6 kBytes
Image
ParadigmShift #3
Member since Dec 2008 · 22 posts
Group memberships: Mitglieder
Show profile · Link to this post
Without posting a screenshot I can tell you my exact settings:

SuRunner (drop-down menu) - DOMAIN\Username
The user can change SuRun settings - unchecked
Require user password for SuRun settings - unchecked
User can only run predefined programs with elevated rights - CHECKED
Install new Hardware automagically as administrator - CHECKED
Hide SuRun from this user - unchecked
Display user status in taskbar - unchecked
Display user status as 'Balloon-Tips' - unchecked

This is my default configuration and it has always worked fine on other PCs. All of a sudden on this one PC I get the permissions error. "You may not have the appropriate permissions to access the item." All the programs added in large window are a 'whitelist', they are supposed to have elevated rights. Once the programs are removed from the 'whitelist', they open fine. It is as though SuRun sees the programs added in the window as a 'blacklist' and they are denied permissions. They will not open at all.
Kay (Administrator) #4
User title: Weltverbesserer
Member since Nov 2007 · 1508 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
Sorry for the long delay! I just did not get spare time for all the checks.

You found a big bug! Thanks for reporting. :-)

If SuRun required the user's password and the program to be started was marked with "Automatically start this program with elevated rights.", SuRun GPF'ed internally and the user got a message box saying something like  "Access denied".

This has (hopefully) been fixed in SuRun 1.2.0.9 Beta 8.
ParadigmShift #5
Member since Dec 2008 · 22 posts
Group memberships: Mitglieder
Show profile · Link to this post
Hello Kay and thank you for testing. SuRun 1.2.0.9 Beta 8 works ok. No more 'Access Denied' error.

Under Common Settings this is what I always use:

Safe Desktop - all boxes are unchecked
Security - all boxes are unchecked with 'No Users' in the 'Show Warning' menu
Shell Integration - 1 box CHECKED - 'Show "Start as administrator" in the system menu of applications'
Convenience - 1 box CHECKED - 'Show SuRun settings for experienced users'

I uninstalled v1.2.0.8 and went back to v1.2.0.6, but I still got the same 'Access Denied' error. Maybe v1.2.0.8 leaves files and registry entries behind after uninstalling. However, v1.2.0.9 Beta 8 works fine. Thank you.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Not logged in. · Lost password · Register
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 45 ms (22.1 ms) · 61 database queries in 7.5 ms
Current time: 2019-08-20, 03:44:08 (UTC +02:00)