Forum: SuRun English speaking RSS
Applications with problems
xdmv #1
Member since Jun 2009 · 20 posts · Location: Glendora, US  / Santa Fe, AR
Group memberships: Mitglieder
Show profile · Link to this post
Subject: Applications with problems
Dear Kay:

I found two apps with error when starting as SuRunner:

- Sony Sound Forge 9.0 build 441
Starting this app as SuRunner shows this error:

An error occurred during the current operation.
An exception has occurred.

Sony Sound Forge 9.0
Version 9.0e (Build 441)
Exception 0xC0000005 (access violation) READ:0x214 IP:0x32CAE2AC
In Module 'forgek.dll' at Address 0x32C50000 + 0x5E2AC
Thread: GUI ID=0xB94 Stack=0xDC000-0x130000
Registers:
 EAX=00000000 CS=001b EIP=32cae2ac EFLGS=00210206
 EBX=000dc380 SS=0023 ESP=000dc1b8 EBP=00130274
 ECX=0020ca28 DS=0023 ESI=000dc380 FS=003b
 EDX=00000001 ES=0023 EDI=00000000 GS=0000
Bytes at CS:EIP:
 32CAE2AC: F7 80 14 02 00 00 00 01 ........
 32CAE2B4: 00 00 8B E9 74 13 8B 80 ....t...
Stack Dump:
 000DC1B8: 006AB208  00400000 + 2AB208 (Forge90.exe)
 000DC1BC: 00130274  00130000 + 274
 000DC1C0: 00000019
 000DC1C4: 000DC2C0  00030000 + AC2C0
 000DC1C8: 011E9CD8  011E0000 + 9CD8
 000DC1CC: 05400910  05400000 + 910
 000DC1D0: 00410F6F  00400000 + 10F6F (Forge90.exe)
 000DC1D4: 000DC380  00030000 + AC380
 000DC1D8: 000DC380  00030000 + AC380
 000DC1DC: 004105A0  00400000 + 105A0 (Forge90.exe)
 000DC1E0: 000DC27C  00030000 + AC27C
 000DC1E4: 00000000
 000DC1E8: 011E8E50  011E0000 + 8E50
 000DC1EC: 011E8E50  011E0000 + 8E50
 000DC1F0: 00000000
 000DC1F4: 000DC1E4  00030000 + AC1E4
> 000DC204: 7E44048F  7E410000 + 3048F (USER32.dll)
> 000DC208: 7E429350  7E410000 + 19350 (USER32.dll)
> 000DC210: 7E42934B  7E410000 + 1934B (USER32.dll)
> 000DC214: 5AD8C43C  5AD70000 + 1C43C (uxtheme.dll)
> 000DC224: 5AD73935  5AD70000 + 3935 (uxtheme.dll)
> 000DC234: 5AD739D6  5AD70000 + 39D6 (uxtheme.dll)
> 000DC23C: 004105A0  00400000 + 105A0 (Forge90.exe)
  000DC240: 00000000
  000DC244: 00130274  00130000 + 274
  000DC248: 0000002B
  000DC24C: 00000000
> 000DC254: 7E418734  7E410000 + 8734 (USER32.dll)
> 000DC268: 004105A0  00400000 + 105A0 (Forge90.exe)
  000DC26C: DCBAABCD
  000DC270: 00000000
  000DC274: 000DC380  00030000 + AC380
> 000DC278: 004105A0  00400000 + 105A0 (Forge90.exe)
- - -
 0012FFF0: 00000000
 0012FFF4: 00000000
 0012FFF8: 006051BB  00400000 + 2051BB (Forge90.exe)
 0012FFFC: 00000000


- O&O Defrag Professional 11.0 build 3265
Starting this app as SuRunner shows this error:
(O&O service is already running...)

The connection to O&O Defrag Agent could not be established. Possibly, the O&O Defrag service has not been started. You can manually start it using the Windows Services Management.

Access is denied.
(5)



Both apps running as any User from Administrator group start without problems.

Thanks in advance!
Koharubi #2
Member since Jul 2009 · 6 posts · Location: Eastern Seaboard
Group memberships: Mitglieder
Show profile · Link to this post
I can confirm that O&O Defrag Pro v11.5 (build 4101) displays the same error on my machine, both with "Start as Administrator" or not. Tried with 1.2.0.6 and 1.2.0.7b11. It works without SuRun. I attached my Process Monitor event logs.

SoundForge 9.0e (build 441) seems to work fine on my computer (Win XP SP3), both with "Start as Administrator" or not.
The author has attached one file to this post:
OO_Defrag_Pro_Process_Monitor.7z | Save   148.9 kBytes, downloaded 115 times
This post was edited 2 times, last on 2009-07-27, 23:56 by Koharubi.
Kay (Administrator) #3
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
I'm currently on vacation until August 10th. I'll test when I'm back.
Kay (Administrator) #4
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
So.... It took a while to find time for testing.
  • I just installed O&O Defrag in a VM, (no system restart), tried to start O&O Defrag, SuRun asked to start it as
Admin, "OK": Same Error  :huh:
  • Started O&O Defrag as user "Administrator", same Error  :-/

  • Started the computer management mmc, restarted the service "O&O Defrag".

  • Started O&O Defrag as user "Administrator", same Error  everything works fine :-D
  • Started O&O Defrag, SuRun asked to start it as Admin, "OK", everything works fine  :huh:

  • Restarted the VM, same Error as after Installation  :#:
  • Restarted the service,  "Start as Administrator..." fails, RunAs "real Administror" works, "Start as Administrator..." afterwards work... Hmmmmm  :nuts:

It seems that a real Admin must open the "gate" to O&O Defrag before a SuRun-Admin can go through it.  :rolleyes:

I don't know how SuRun could handle such a situation in a generic manner.
Any ideas?
xdmv #5
Member since Jun 2009 · 20 posts · Location: Glendora, US  / Santa Fe, AR
Group memberships: Mitglieder
Show profile · Link to this post
Hi Kay!

It seems O&O soft requires to be a member of administrator group.
SuRunners do not apply to that option.

Is there some way to make a surunner belong to administrator group for a particular application?
Or just "cheat" the application?

Thanks!
Kay (Administrator) #6
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
You could use SuRun to start a script that puts you in the Admin group, starts O&O, waits for it to run and removes you from that group.

But I don't recommend the group thing! Anything logging in with your credentials while you're in the Admin group will become real Admin. Spying passwords is too easy!

A defragger should not need administrator privileges anyway.

I'd suggest using a different defragger that does not have these restrictions.
Cosmo #7
Member since Mar 2008 · 451 posts
Group memberships: Mitglieder
Show profile · Link to this post
Defragmenting with the XP tool needs admin privileges. I do this via RunAs without any problems (for defragmenting is not the smallest need to do this with the own user context)
Thomas
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Not logged in. · Lost password · Register
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 68.8 ms (37.6 ms) · 79 database queries in 23.5 ms
Current time: 2019-12-11, 21:49:59 (UTC +01:00)