Forum: SuRun Zickende Software RSS
MOD4WIN
Avatar
trekkie22 #1
Member since Nov 2008 · 19 posts · Location: Leinfelden-Echterdingen
Group memberships: Mitglieder
Show profile · Link to this post
Subject: MOD4WIN
Mir ist gerade aufgefallen, daß MOD4WIN beim beenden rumzickt, wenn ich es nicht als Admin starte.

Beim beenden kommt ein "MOD4Win Error" "Warning: Could not remove font" (siehe Anhang).

Hast Du mir einen Tipp, ob ich das ohne SuRun loskriege bzw. obs ein Problem darstellt, wenn ich den Fehler einfach ignoriere? Natürlich könnte ich es automagisch als Admin starten, aber rein für die Funktion ist das ja eigentlich nicht notwendig, läuft ja einwandfrei...

<EDIT>Rechte habe ich geprüft, da sollte es keine Probleme geben, ich habe als User Vollzugriff auf das Verzeichnis...</EDIT>
The author has attached one file to this post:
mod4win.jpg | Save   7.3 kBytes
Image
Kay (Administrator) #2
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
Wow... das ist lange her. (Ich sehe gerade, dass ich damals Titel und Inhalt der Meldung vertauscht habe... Hmmm)

MOD4WIN benutzt einen eigenen Fixed-OEM-Font zur Anzeige, den es installiert und beim Beenden wieder löscht.
Geht das Löschen nicht, meckert MOD4WIN mit der Meldung oben.

Das ist nicht weiter tragisch, denn die Datei "m4w????.FON" belegt pro MOD4WIN-Start rund 30kBytes in Deinem TEMP Verzeichnis. Das ist (auch nach Jahren noch) deutlich weniger, als die Zusatzsprachen, die z.B. Acrobat Reader ungefragt mitinstalliert. ;-)

Seltsamer Weise bekomme ich hier die Meldung allerdings nicht, wenn ich MOD4WIN mit eingeschränkten Rechten starte...
Jon #3
Member since Jan 2009 · 14 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post #1
Mod4Win ändert ein paar Einträge in der win.ini und system.ini im Windows-Verzeichnis. Wenn Du für beide Schreibrechte hast kommt die Meldung nicht mehr.
SuRun 1.2.1.2
Windows 7 x64
Kay (Administrator) #4
User title: Weltverbesserer
Member since Nov 2007 · 1509 posts · Location: Magdeburg
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
Das kann's nicht sein.
Ich habe keine Schreibrechte auf beide Dateien und sehe die Meldung nicht.

Oh! Ich sah gerade in meine letzte WhatsNew.TXT:

2006/12/10
  • German Umlauts in Bitmap Fonts are replaced by latin equivalents
  • MOD4WIN does not complain anymore about not removed Font resource

...das wird's sein.

Oh, noch was...das war bis jetzt noch nicht Online...wird Zeit!  :blush:

So! Hab's hochgeladen.
Avatar
trekkie22 #5
Member since Nov 2008 · 19 posts · Location: Leinfelden-Echterdingen
Group memberships: Mitglieder
Show profile · Link to this post
Perfekt!

Keine Fehlermeldung mehr.  :-)

Danke!
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Not logged in. · Lost password · Register
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 49.2 ms (21.1 ms) · 66 database queries in 7.8 ms
Current time: 2019-09-20, 03:58:15 (UTC +02:00)