Forum: SuRun Beta RSS
SuRun 1.2.0.6
Seite:  vorherige  1  2  3  4  5 
Kay (Administrator) #61
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Antwort auf Beitrag ID 1592
Zitat von Cosmo:
Während? Automatisches Update oder wie das? (Ich hatte den IE7 schon von vorneherein dem frischen XP SP3 hinzugefügt.)

Ich installiere XP zu selten... habe noch die originale CD mit integriertem SP3 ;-)

Zitat von Cosmo:
Nur die Geschichte, daß du bei Beta 11 geschrieben hattest, daß das Problem mit VB jetzt erledigt sein sollte, daß dann aber erst mit Beta 13 für mich reproduzierbar wurde, und dann bei RC1 wieder auftrat, war / ist doch recht verwirrend.

Vorgestern hätte ich noch nicht gedacht, dass VB so lahm ist und hatte vermutet, dass die falsche Speicher-Freigabe zu dem Verhalten in VB führte.

Das mit der Performance ist nicht immer nachzuvollziehen. Während ich die Routinen für Verdunkelung und Unschärfe des Hintergrundes optimiert habe, ergaben Performance-Messungen manchmal 50% Unterschied, wenn man einfach zwei Zeilen im Quelltext vertauscht hat. Ähnliches hatte ich auch schon vor elf Jahren bei Tests mit optimierten FPU-Assembler-Routinen für kubische Interpolation und schnelle Fourier-Transormation, ein NOP am richtigen Platz und alles lief 20% schneller. Ich denke, dass die Caches aktueller CPUs immer gut gefüllt sein müssen und keine Ungereimtheiten aufzeigen dürfen, um maximal performant zu laufen.

Ich vermute, dass Änderungen in SuRun dazu geführt haben, dass die Filter-Routinen des unscharfen Desktop jetzt ein paar Bytes weiter hinten/vorn im Code stehen und dadurch etwas langsamer laufen.

Zitat von Cosmo:
Übrigens, was Performance betrifft: Du hast natürich recht, was VB betrifft. Das hat aber in diesem Fall auch etwas positives: Du kannst dir mal selber eine Vorstellung machen, wie sich mir das Forum darstellt: Das bereits wiederholt diskutierte Problem des schleppenden Bildaufbaus auf deinem Forum in der physischen(!) Maschine ist noch größer als die Verzögerung des Bildaufbaus in VB.

Ein anderes Forum steht noch auf meiner ToDo-Liste...wenn auch recht weit hinten ;-)
Cosmo #62
Mitglied seit 03/2008 · 451 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Zitat von Kay:
Zitat von Cosmo:
Während? Automatisches Update oder wie das? (Ich hatte den IE7 schon von vorneherein dem frischen XP SP3 hinzugefügt.)

Ich installiere XP zu selten... habe noch die originale CD mit integriertem SP3 ;-)
Jetzt verstehe ich gar nichts mehr. Abgesehen davon, daß ich mir nicht sicher bin, ob es eine originale (!) XP-CD mit integriertem SP3 überhaupt gibt (zumindest was Pro betrifft - ich kenne nur die Slipstream-Möglichkeit), auch SP3 enthält kein IE7, der muß immer separat nachinstalliert werden. Deswegen wundere ich mich über das, was da bei dir passiert ist. Zumal beim IE7 IIRC immer erst eine Eula abzunicken ist geht da nichts von alleine.
Thomas
Kay (Administrator) #63
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Ich hatte mich missverständlich ausgedrückt.
Ich habe eine originale Windows XP CD (ohne SP) auf Platte kopiert, SP3 integriert und davon wieder ein ISO gemacht. Mit der CD installiere ich neue Systeme. IE7 ist da nicht drauf.
In der VM waren automatische Updates aktiviert und IE7 wurde damit installiert.
Cosmo #64
Mitglied seit 03/2008 · 451 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Na, dann hat das mit dem SuRun / VB Problem ja nichts zu tun, wie ich schon meinte.
Thomas
Kay (Administrator) #65
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Ich habe SuRun 1.2.0.6 freigegeben.
Cosmo #66
Mitglied seit 03/2008 · 451 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hm, ich habe die finale 1.2.0.6 zum ersten Mal (unter den 6ern) auf einer physischen Maschine mit 32 Bit XP SP3 installiert.

Reproduzierbar erscheint nach dem Aufruf die Eieruhr für 2 Umdrehungen (der Uhr), egal in welchem Konto. Zwar kein Watchdog, aber es erinnert mich doch an das VB-Problem.

Ich hab das ganze dann noch einmal in einem "leeren" System installiert (leer, kein AV, HIPs sowiso nicht, und auch sonst keine Systembremsen, Automatische Updates abgeschaltet). Exakt das gleiche Verhalten, selbst dann, wenn ich den unscharfen Desktop ganz abschalte.

Das ganze auf einem Core 2 Duo System mit 2,66 GHz und 2 GB RAM. Also auch an der Hardware kann es nicht liegen.

Und: Auf Grund der offensichtlichen Verzögerung - schon beim Aufuf und bevor der SuRun-Dialog erscheint - hatte ich zweimal auf das Tray-Symbol doppelt geklickt (weil ich glaubte, daß der erste Doppelklick nicht richtig gewesen sei). Resultat: Nach dem Schließen des SuRun-Dialoges kam er sofort danach gleich noch einmal. Sollte wohl auch nicht so sein. Ohne die Verzögerung wäre das natürlich nicht passiert, aber vielleicht sollte SuRun doch einen Check machen, ob eine Instanz des Dialoges bereits offen ist.
Thomas
deroppi #67
Mitglied seit 12/2008 · 22 Beiträge · Wohnort: Frankfurt
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Ich kann das von Cosmo im letzten post geschilderte Verhalten nachvollziehen.
Kay (Administrator) #68
Benutzertitel: Weltverbesserer
Mitglied seit 11/2007 · 1473 Beiträge · Wohnort: Magdeburg
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Ich mache dann hier mal zu und SuRun 1.2.0.7 Beta auf...
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Seite:  vorherige  1  2  3  4  5 
Gehe zu Forum
Nicht angemeldet. · Kennwort vergessen · Registrieren
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Seite erstellt in 130,5 ms (53,5 ms) · 87 Datenbankabfragen in 22 ms
Aktuelle Zeit: 18.12.2017, 23:09:54 (UTC +01:00)