Page:  1  2  3  next 

All posts by Stefan (42)

topic: SuRun 1.2.1.0  in the forum: SuRun Beta
Stefan #1
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
Nach langer Zeit melde ich mich mal wieder:
Das Symbol ist eigentlich etwas, was ich mir für SuRun gewünscht habe. Einziges Problem: "Als Administrator ausführen" (Windows) und "Starte als Admininstrator" (SuRun) liegen genau übereinander, sodass es nicht ganz den vom Icon erhofften Schnellerkennungswert hat (ein Blick, und ich weiß, welches der SuRun-Menüeintrag ist). Besser wäre für mich also ein eigenes SuRun-"Starte als Administrator"-Icon.
Aber das ist Nörgeln auf hohem Niveau. Bei "Neustart als Administrator" taucht das Schild-Icon klaglos auf; es scheint also zu funktionieren

Eine gute Nachricht: Auf meinem System (Windows 7 x64) gibt es mit der jetzigen Version anscheinend keine Probleme mit Apoint.exe mehr, sodass ich das Programm nicht mehr in die Ausnahmeliste für Hooks nehmen muss. Ich werde sehen, ob das auch nach einigen Restarts gilt. (Apoint.exe ist Bestandteil meines Touchpad-Treibers von ALPS.)
topic: UAC fragt nach Passwort anstelle von SuRun ?!  in the forum: SuRun Probleme
Stefan #2
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 3184
Ach ja, wenn Du keine UAC-Abfragen (mit Passwort) mehr haben willst, wenn Du als Standardbenutzer arbeitest, so gibt es tatsächlich die Möglichkeit, UAC für Standardbenutzer zu deaktivieren. Dann verhält sich das Konto wieder so wie ein Standardbenutzerkonto unter XP, und die einzige Möglichkeit, etwas administrativ zu starten, ist "Ausführen als..." und SuRun. (Wie man UAC für Standardbenutzer deaktiviert, müsste ich allerdings nachsehen.)
topic: UAC fragt nach Passwort anstelle von SuRun ?!  in the forum: SuRun Probleme
Stefan #3
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 3183
Hallo Silentium,

ich bin kein Experte in der Windows-Architektur, deshalb eine Antwort eines Laien...

Wenn ich beispielsweise als Benutzer die Einstellungen vom Windows-Update ändere und diese Änderungen übernehmen möchte, dann meldet sich nicht SuRun sondern wieder UAC (mit Aufforderung, das Passwort des Admin-Kontos einzugeben). Bin jetzt ein wenig verwirrt, wieso dies so ist. Damit ist doch der Sinn und Zweck von SuRun "ausgehebelt", da in solchen Situationen das Admin-Passwort wieder ausgehorcht werden könnte. Oder muss ich irgendwelche Einstellungen ändern?
Das ist das normale SuRun-Verhalten. Mit SuRun kann man Programme ohne Passwortabfrage administrativ starten, auch wenn man nur Standardbenutzer bist. Um das zu tun, klickt man mit der rechten Maustaste auf ein Programmicon und wählt "Starte als Administrator" (nicht zu verwechseln mit dem Windows-eigenen "Als Administrator ausführen" mit dem Schild-Icon).
- SuRuns "Starte als Administrator" -> Keine Passwortabfrage
- Windows "Als Administrator ausführen" -> Passwortabfrage.

Zudem hat SuRun den Vorteil, dass man Programme sogar ganz ohne Abfrage automatisch als Administrator starten lassen kann.
SuRun ersetzt allerdings nicht die UAC-Dialoge bei Änderungen von Windows-Einstellungen oder wenn man z.B. eine Datei ins Windowsverzeichnis kopiert, hier erscheint weiterhin die UAC-Abfrage. SuRuns Zweck ist aber auch nicht, diese Dialoge zu ersetzen, stattdessen erlaubt es SuRun eben nur, einzelne Programme mit erhöhten Rechten ohne Passwortabfrage zu starten.

Übrigens wird das Passwort auch bei den UAC-Dialogen über einen sicheren Desktop abgefragt und kann somit nicht abgehorcht werden. (Es gibt das theoretische Szenario, dass ein bösartiges Programm eine gefälschte UAC-Abfrage mit Passwortabfrage anzeigt, um so ein Adminpasswort zu stehlen und per Internet an einen Hacker zu melden - deswegen hat Microsoft auch auf die Passwortabfrage beim normalen UAC-Admin verzichtet, um dieses "Angriffsszenario" zu unterbinden. Letztendlich ist das aber ein Szenario, das m.E. noch nicht vorgekommen ist, denn man wird ja von selbst stutzig, wenn plötzlich eine UAC-Abfrage auftaucht, ohne dass man ein Programm administrativ gestartet hätte o.ä.)

Was mir noch aufgefallen ist: Der Benutzer ist Mitglied der Gruppe "SuRunners" und "Benutzer". Muss der Benutzer aus der Gruppe "Benutzer" ausgetragen werden und damit nur Mitglied von "SuRunners" sein oder ist das so ok?
Das ist o.k. so.
topic: DLL-"Lücke" oder CWDIllegalInDllSearch  in the forum: SuRun Wunschliste
Stefan #4
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2938
Mittlerweile hat MS ein "Fix it"-Tool entwickelt, das den (nicht ganz so strengen) Registry-Wert 2 einträgt, allerdings muss man vorher den eigentlichen Patch selbst installieren. (Siehe den entsprechenden Artikel bei Heise Security.) MS scheint sich noch zu überlegen, wie das Ganze endgültig gehandhabt werden soll. Ansonsten denke ich auch, dass die ganze Konfiguration besser in einem eigenen Programm aufgehoben ist als in SuRun.
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #5
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2872
Quote by Kay on 2010-07-30, 21:05:
@Stefan: Du musst Apoint.exe wohl in die Liste der Ausnahmen aufnehmen. Ich habe einiges probiert, den IAT-Hook zu verändern, aber dann lief mein eigenes System nicht mehr stabil.
Kein Problem. :-) Danke für Deine Überlegungen & Bemühungen!
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #6
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2819
Quote by Kay on 2010-06-30, 11:13:
Ja. Der Explorer ist ein out-of-process COM objekt. Die EXE wird aber nach ~40s beendet.
Verhalten bestätigt. Ich hätte nur etwas länger warten sollen. Gut, dass es doch kein Problem gibt.

Quote by Kay on 2010-06-30, 11:13:
Quote by Stefan:
Ist es eigentlich eine mögliches Sicherheitsrisiko, wenn man unter Windows 7 plötzlich den Explorer mit erhöhten Rechten starten kann?

...Hmmm.
Wäre es vielleicht eine Option, dass die entsprechenden Registrykeys erst gesetzt werden, wenn man "Zeige 'SuRun Explorer' hier" aktiviert (und dass sie beim Deaktivieren wieder ausgetragen werden)? Andererseits lohnt der Aufwand dafür wohl nicht.

Quote by Kay on 2010-06-30, 11:13:
Quote by Stefan:
Apoint.exe [...] kann nicht gestartet werden, wenn ich mich anmelde. Zudem startet WinDbg und gibt einen Analysetext aus (den ich angehängt habe).

Prima, der Text!!!
Die Schutzrechtverletzung kommt in "LoadLibExW", das ist die IAT-Hook-Funktion für LoadLibraryExW.

Windows hat SuRunExt.dll bereits entladen, Apoint ruft aber noch mal LoadLibraryExW auf.
Der Hook biegt die Funktionen beim Entladen der Dll wieder von "LoadLibExW" auf LoadLibraryExW zurück.
Wenn aber Apoint.exe noch einen Pointer auf die Funktion gespeichert hat, springt das Programm an die Stelle, die nicht mehr geladen ist und Peng!

Beta 12 versucht nun, das Entladen von SuRunExt.dll zu verhindern.
Leider gibt es den Absturz immer noch. Anbei wieder der Fehlertext, ich hoffe, dass Du die Ursache wieder entdecken kannst.
The author has attached one file to this post:
Fehler.TXT | Save   16.6 kBytes, downloaded 125 times
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #7
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2815
Ich habe die neue SuRun-Beta installiert, das Starten von Explorerfenstern mit erhöhten Rechten funktioniert.
Dummerweise ist ein (für mich) alter Bekannter aus XP-Zeiten wieder aufgetaucht: Wenn ich das administrativ gestartete Explorerfenster schliesse, bleibt laut Process Explorer ein Explorer-Prozess übrig, der sich nicht beendet, also ein Zombieprozess... Tritt das Verhalten auch bei anderen auf?
Selbst wenn nicht: Ich selbst benötige die Funktion "SuRun Explorer hier" nicht, ich kopiere selten Dateien ins Programmverzeichnis u.ä., und wenn, dann gebe ich über den UAC-Dialog das Admin-Passwort ein (ich arbeite als Standardbenutzer). Sollte die Funktion also nur bei mir nicht richtig funktionieren, macht das nichts.

Ist es eigentlich eine mögliches Sicherheitsrisiko, wenn man unter Windows 7 plötzlich den Explorer mit erhöhten Rechten starten kann?

EDIT: Beim Anmelden gab es ein Problem: Apoint.exe (das Zusatzprogramm für mein Touchpad, das das Touchpad z.B. deaktiviert, wenn eine Maus am Notebook angeschlossen ist) kann nicht gestartet werden, wenn ich mich anmelde. Zudem startet WinDbg und gibt einen Analysetext aus (den ich angehängt habe). Als Workaround habe ich Apoint.exe in die Ausnahmeliste von SuRun eingetragen, jetzt funktioniert wieder alles. Liegt dieses Verhalten eventuell am neuen Warteverhalten von SuRun?
The author has attached one file to this post:
Fehler.TXT | Save   16.6 kBytes, downloaded 116 times
This post was edited on 2010-06-29, 19:18 by Stefan.
topic: SuRun 1.2.0.9  in the forum: SuRun English speaking
Stefan #8
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2684
Hello ssj100,
Kay states (somewhere) in this forum that some features do not work yet with Windows 7 (sorry, I do not have a link at hand ;-) ). As you have noticed, "SuRun explorer here" is an example. Apart from that, I am using SuRun 1.2.0.9 Beta 10 with Windows 7 64-Bit and have not encountered any problems. (In fact, even SuRun 1.2.0.8 and earlier already supported 64-Bit Windows versions.)
Concerning the final release of 1.2.0.9: Kay states (in German) at http://forum.kay-bruns.de/post/2666 that he has not time for developing SuRun by the end of April. But I am sure that he will finish SuRun 1.2.0.9 when he has enough time. :-) And I also think that SuRun is a great program!
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #9
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2535
Ich bin dann doch bei Beta 7a auf ein Problem bei mir gestossen (wie ich meine):

Die Druckwarteschlange (Spooler) und die "Erkennung interaktiver Dienste" konnten manchmal nicht gestartet werden, wogegen nur ein Neustart half. (Zumindest beim ersten Dienst hat man es gemerkt, wenn man etwas drucken wollte. ;) ) Warum diese beiden Dienste? Anscheinend, weil sie im Systemkontext gestartet werden und den "Datenaustausch zwischen Dienst und Desktop" erlauben (Eigenschaften des Dienstes unter services.msc -> Reiter "Anmelden"). Entfernte man das entsprechende Häkchen, klappte es auch mit dem Starten. (Wenn ich das Häkchen probeweise bei anderen Diensten gesetzt habe, konnte ich sie dagegen problemlos starten - seltsam.)
Ich vermute jedenfalls, dass es an SuRun Beta 7a lag (die auch in Systemprozesse injiziert), weil das Problem trotz mehrerer Neustarts mit Beta 7 oder ohne SuRun nicht auftrat, während es mit Beta 7a etwa jedes zweite bis dritte Mal nach einem Neustart vorkam.
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #10
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2533
Auch das Treiberproblem hat sich von selbst gelöst: Ich habe testweise den noch älteren, bei Win 7 beiliegenden Grafiktreiber installiert, und schon hat sich Windows Update den allerneuesten aus dem Netz besorgt. Warum er das beim nur etwas älteren Treiber nicht getan hat, weiss ich nicht, aber das ist sicherlich kein SuRun-Fehler.
Das einzig seltsame ist m.E., warum Microsoft Update plötzlich verschwunden war - aber vielleicht habe ich das auch einmal unbewusst deaktiviert?
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #11
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2531
Hallo trekkie22 und Kay,

danke für die schnellen Antworten. Ich habe erst einmal Kays Einstellungen gewählt und die von trekkie22 beschriebenen Registry-Schlüssel gefunden.

Beim Aufrufen von Windows Update ist mir aufgefallen, dass ich Updates "Nur für Windows" erhalte. Ein Klick auf den angebotenen Link führte mich zur Microsoft Update-Seite, und nach der Installation von Microsoft Update wurden die vermissten optionalen Updates angezeigt. Zudem kann man unter "Windows Update > Einstellungen ändern" auch Microsoft Update konfigurieren. Silverlight wird mir nun wieder angeboten, der neuere Grafikkartentreiber aber nicht.
Ich muss aber auch zugeben, dass ich mir im Moment nicht ganz sicher bin: Ich habe etwa seit 1. November ein neues Notebook, auf dem ich Win 7 x64 installiert habe (und es gab keine Probleme mit SuRun :) ). Ob ich jetzt alles mit meinem alten verwechsle, bei dem Microsoft Update bereits vorhanden war? Andererseits musste ich es auf dem alten Notebook nicht extra installieren, und ich bin mir ziemlich sicher, dass Silverlight auch auf dem neuen Notebook (vor der SuRun-Installation) angeboten wurde, inklusive Microsoft Update-Optionen.
Lange Rede, kurzer Sinn: Was genau passiert ist, kann ich leider nicht mit Bestimmtheit sagen, ob (und wenn ja, wieso) Microsoft Update plötzlich nicht mehr vorhanden war und warum mir der neuere Treiber im Moment nicht angeboten wird. Es tut mir leid, dass ich für Umstände gesorgt habe.
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #12
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2526
Hallo Kay,

unter Windows 7 kann man bei "Windows Update > Einstellungen ändern" einen Haken bei "Allen Benutzern das Installieren von Updates auf diesem Computer ermöglichen" setzen - ausser, wenn SuRun installiert ist, dann muss das über die SuRun-Einstellungen erfolgen, und das Kästchen bei Windows Update ist ausgegraut. (Es wird auch darauf hingewiesen, dass "einige Einstellungen ... vom Systemadministrator verwaltet" werden.)
Deinstalliert man SuRun, so bleibt das Kästchen allerdings weiterhin ausgegraut (und ist deaktiviert). Ich denke nicht, dass das beabsichtigt ist, oder? (Aber wer möchte SuRun schon deinstallieren... ;) )
In diesem Zusammenhang habe ich einen anderen Verdacht: Auch wenn das Kästchen "Empfohlene Updates auf die gleiche Weise wie wichtige Updates bereitstellen" aktiviert ist, scheine ich diese nicht mehr zu erhalten. Ich glaube, dass mir vor der SuRun-Installation die Installation von Silverlight angeboten wurde, jetzt nicht mehr.
Aus Testgründen habe ich im Moment eine ältere Version des Grafikkartentreibers installiert. Windows Update bietet mir nun nicht an, einen neueren zu installieren, obwohl das Windows Update vor der SuRun-Installation getan hat (wie ich meine). Könnte SuRun auch mit diesem Problem zusammenhängen?
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #13
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2481
Hallo Kay,

ich habe mich seit etwas längerem nicht gemeldet, und leider habe ich es noch nicht systematisch getestet, aber:
Das Problem scheint behoben zu sein. :) Wenn man das Problem an meinem Computer reproduzieren kann, dann wohl durch einen angesteckten USB-Stick beim Booten oder Einloggen (was ich weiter oben erwähnt habe).
Wenn man unter Windows 7 das Passwort eingegeben hat, erscheint ja "Willkommen" (oder ähnlich) mit dem kreisenden blauen Kreis (was früher die Sanduhr war). Beide Male (mit eingestecktem USB-Stick) blieb der Bildschirm dabei ein oder zwei Sekunden stehen, was ich dahingehend interpretiere, dass die Zugriffsverletzung abgefangen wurde. Dafür spricht auch, dass sich danach das Sicherheitscenter beschwerte, Avira würde nicht laufen (was es aber tat): Dieses Problem trat hin und wieder auch nach den Explorer-Abstürzen mit den alten Betas auf.
Somit gibt es keine Explorer-Abstürze mehr, aber bei eingestecktem USB-Stick beim Booten eine Sicherheitscentermeldung, die man durch De- und Reaktivieren von Avira sofort wieder los wird (und ohne USB-Stick scheint SuRun nichts mehr abfangen zu müssen, weil das Einloggen problemlos klappt).

Vielen Dank nochmals! :)
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #14
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2475
Es ist schon wieder passiert. Verflixt! Beim Einloggen meldete Windows, dass der Explorer abgestürzt ist und neu gestartet werden muss.

Der einzige Unterschied war, dass ich diesmal beim Booten einen USB-Stick angeschlossen habe. Ich habe gerade eben wieder einen Neustart durchgeführt und dabei den USB-Stick eingesteckt, doch jetzt ist nichts passiert...

Fehlerbucket , Typ 0
Ereignisname: APPCRASH
Antwort: Nicht verfügbar
CAB-Datei-ID: 0

Problemsignatur:
P1: Explorer.EXE
P2: 6.1.7600.16385
P3: 4a5bc60d
P4: SuRunExt.dll_unloaded
P5: 0.0.0.0
P6: 4ad3431a
P7: c0000005
P8: 10004da0
P9:
P10:

Soll ich wieder die Reportdatei hochladen?
topic: SuRun 1.2.0.9  in the forum: SuRun Beta
Stefan #15
Member since Aug 2008 · 42 posts
Group memberships: Mitglieder
Show profile · Link to this post
In reply to post ID 2474
Ich habe die neue Beta 6 installiert und das System 3 Mal gestartet. Es ist nichts ungewöhnliches passiert. Das "Login-Problem" besteht weiterhin, ist aber nicht so ernst.
Das ganze ist hoffentlich kompatibel und performant genug, um nicht aufzufallen.
Eine Verzögerung habe ich bemerkt: Nach der Passworteingabe verschwindet ja der Login-Schirm. Beim zweiten und dritten Mal schien es danach etwas länger zu dauern, bis die Symbole auf dem Desktop erscheinen etc., d.h. der Desktop richtig geladen ist. Aber abgestürzt ist nichts. (Und da mein System von der Power sowieso nicht recht repräsentativ ist...)
In der beiliegenden Beta habe ich die Hook-Initialisierung in einen eigenen Thread ausgelagert...
Beeindruckend, wie Du immer wieder Lösungen aus dem Hut zauberst!  :-)
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  3  next 
Special queries
Go to forum
Not logged in. · Lost password · Register
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 131.3 ms (110 ms) · 154 database queries in 32.9 ms
Current time: 2019-08-18, 13:44:07 (UTC +02:00)